
Accessibility Guidelines
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Office of Accessibility and Disability Resources

The Value of Making Accessibility a Priority

By making your website, newsletter, social media, PDFs, etc., accessible using best practices, you are ensuring that all of your 
potential users, including people with disabilities, have a good user experience and are able to easily access your information. 

Accessibility can:

Drive Innovation: Accessibility features in products and services often solve unanticipated problems.

Enhance the Brand: Diversity and inclusion efforts that are so important to business success, and to fostering a sense of belonging 
and value of all, are accelerated with a clear, well-integrated accessibility commitment.

Extend Market Reach: The global market of people with disabilities is more than 1 billion individuals with a spending power of more 
than $6 trillion. And accessibility enhancements often improve the online experience for all users.

Minimize Legal Risk: This issue is of increasing legal concern, with many countries having laws requiring digital accessibility.

The Division of Strategic Communication and Engagement and the Office of Accessibility and Disability Resources recognize 
the critical nature of accessibility, and to that end have collaborated to produce this document, which gives an overview of best 
practices in accessibility for digital media—websites, PDFs, emails, images, and social media. Following these guidelines will 
greatly enhance your digital communication, making it available to a wider audience and improving brand reputation. We encourage 
you to familiarize yourself with the content in this document, created in practical support of the university’s Electronic Information 
Technology Accessibility Policy. Please keep in mind that this document provides only a general introduction to creating 
accessible digital content and does not capture all accessibility guidelines or detailed instructions for the many computer 
programs available to users.
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Accessible Images 
Images are an important part of many types of digital 
communication, from websites to emails to social media posts. 
But inaccessible images are of no benefit to disabled users, and 
may drive them away from your content. According to Click-Away 
Pound, 71% of disabled customers with access needs will click 
away from a website that they find difficult to use, and more 
than 90% of customers who have trouble navigating a website 
either will not, or cannot, contact the organization. To best serve 
disabled users, adhere to the following guidelines:

•	 Images containing text should be avoided if at all possible. 
The exception is for images in which the text is an intentional 
piece of the visual design of the element:

	 °	 Logos
	 °	 Badges
	 °	 Event flyers or posters

	 Note, however, that in these cases, the content included in  
the image should be presented alongside the image (e.g.,  
a picture of the related event flyer while you’re talking about 
the event). You cannot work around this practice by using  
an image of the flyer as the page’s header image to meet the 
no-text rule.

•	 Make sure every image has an appropriate alt attribute. 
Because images are a visual-only medium by definition, they 
can cause problems when used as part of the content of a 
page; visually impaired readers may not be able to receive 
the content the images are presenting. Alternative (alt) text 
resolves this issue by describing the image for readers (and 
computer systems) who cannot see it.

•	 If you set an empty alt attribute (e.g., alt=“”), this means that 
the image is visual decoration only, and has no bearing on the 
actual content of the page—for example, a custom-designed 
section separator, or a visual version of text content that 
already exists on the page.

•	 Otherwise, you should describe the image to the reader as 
helpfully as possible:

	 °	 If it’s a photo, describe the content of the photo: “Two 	  
	 students carry furniture into Trinity Hall on move-in day.”

	 °	 If it contains important information that doesn’t exist  
	 anywhere else in the page content (e.g., an org chart),  
	 describe the point it’s trying to make: “Jim manages the  
	 project committee and reports to Jill, who reports to the  
	 board.”

	 °	 If it’s one of those special elements described earlier, like  
	 an event flyer, you can say something like, “ScholarFest  
	 flyer.” Keep in mind that any information on the flyer should  
	 also be included in the content of the page or caption to  
	 allow all readers to see the information.

	 °	 View the section on “Writing Good Alt Text” for 	additional  
	 tips and guidelines.

•	 Make sure the image will resize correctly on all screen  
widths (e.g., desktop, mobile, etc.) without making any 
wrapping text difficult to read. This means it should  
be configured with the appropriate width percentage  
and max-width. Because this can be a complex process  
that must take additional context into account, contact 
stratcomm@apu.edu for assistance from the web team.

Images and Email Platforms

Depending on which email platform you are using, you might 
be able to enter alt text by manually editing the HTML in your 
email. First, if your email program allows, enable the HTML editor 
in your email or newsletter platform. After the URL for each 
image, add the alt attribute followed by the equals sign and the 
alternative text in quotations (e.g., alt=“text goes here”).

•	 Use helpful descriptions in alt tags within your images.

Checking for High Color Contrast

Using effective color contrast in your campaigns is generally a 
good design choice, but it’s especially important for people with 
color blindness. 

Use the following helpful tools to check the contrast ratio 
between text and background:

webaim.org/resources/contrastchecker
contrast-ratio.com

Do

Don’t
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Accessibility of Social Media
Accessibility within social media platforms is essential to ensuring 
that your content can be experienced by all users. For example, 
Twitter studies note that photos average a 35% boost in retweets 
and videos get a 28% boost in retweets—but disabled users  
may counter that success if they’re frustrated. From adding 
alt text to images to ensuring that videos have captions, the 
following guidelines can help you build stronger connections  
with your audience. 

Using Alt Text in Social Media

• 85% of consumers feel that how a brand handles issues on
its website or social channels is a good indicator of its quality
of support, according to Liveops. This is why alt text is so
important.

• As a rule, every image in your social posts should have alt
text. If you don’t accommodate users who need alt text, you
likely won’t know they’ve missed your point if they simply
disregard your organization instead of taking the time to
complain.

• If you are unable to add alt text to the image within the social
media platform, you can instead describe the image in the
body of the post.

• View additional tips for adding alt text by platform below.

Writing Good Alt Text

• Reflect on the purpose of the image and use alt text to
provide the who, what, and where. Alt text should be clear,
concise, and informative.

• Write in plain language to ensure that people with slower
processing speed or cognitive impairments can understand
each social media post.

• Best practices for writing in plain language include:

°	 Choosing words that are common and easy to understand

°	 Avoiding run-on sentences

°	 Using clear, short sentences and paragraphs

°	 Writing in the active voice instead of the passive voice

• A 2019 Carnegie Mellon University study resulted in
researchers identifying five guidelines people should keep
in mind when writing alt text in order to best translate an
image’s humor:

°	 Explain characters’ actions.

°	 Explain emotions.

°	 Explain facial expressions.

°	 Identify the source (such as TV or film).

°	 Describe anything distinct about the background.

Creating Clear Captions

• Within social media post captions, lead with your main
message.

• Put hashtags and @mentions at the end of a post. This is very
important for screen reader users.

• If a post contains a link to an image, video, or audio, indicate
this at the beginning of the content using the prefix [PIC],
[VIDEO], or [AUDIO] so screen reader users can anticipate
what they will find when they follow the link.

• Also, if a post includes one of these items, be sure to link
back to the webpage that contains the image, video, or audio
with captions and a transcript.

Using Hashtags and Emojis

• For hashtags with multiple words, capitalize the first letter of
each word to make it easier to read visually and for screen
readers. For example, use #BackToSchool not #backtoschool.

• Limit your use of emojis. While they are a fun addition to
captions, too many emojis can hinder the readability of your
content for screen readers. Followers using a screen reader
hear descriptions of the emojis, which can slow down and
disrupt the flow of your message.

• When using emojis, limit use to 1-3 per caption. It’s also best
to save emojis for the end of your message.

Accessible Links in Social Media and Email 

Use meaningful link text (avoid using link text such as “here” or 
“click here”).

Twitter: Adding Alt Text

• Image description functionality is not enabled by default.

1. Navigate to Settings and Privacy.

2. Click Accessibility.

3. Click the checkbox next to Compose image descriptions.

• After you’ve enabled image descriptions, the next time you
attach an image to a tweet:

1. Click Add Description.

2. Enter your alt text.

3. Click Done.

• Note: The image description is limited to 420 characters.
Using clear, concise captions is best.

Need for Accessibility of Social Media

“If you consider the spending power of the disability 
community, you’re talking about a half-a-trillion-dollar  
industry: $490 billion. That’s what people with disabilities 
spend a year in consumption. So why wouldn’t you want  
to be one of the brands that cater to that demographic? 
Parallel to that, it is well known that people within the  
disability community are one of the most, if not the most,  
loyal brand advocates. A lot of companies do not cater to 
them, so when they find a company catering to their needs, 
they are very loyal, often becoming brand ambassadors.”

Daryn Harpaz 
Website Content Accessibility Guidelines (WCAG) 
Compliance Specialist 
Founder and CEO, ZenythGroup, LLC
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Facebook: Adding Alt Text and Video Captions

•	 Facebook tries to recognize common objects and concepts  
in photos and automatically generates alt text.

•	 Of course, as with anything autogenerated, you want to 
proofread and edit it to make sure the image’s intent is 
conveyed:

	 1.	 Select Edit Photo.

	 2.	 Select Alt Text.

	 3.	 Review the content, and click “Override generated alt text”  
		  to edit.

	 4.	 Make any necessary changes and click Save.

•	 For videos, Facebook makes it simple to add captions to 
videos via the .srt file format. If you don’t know how to create 
an .srt file, you can upload your video to YouTube first and use 
their captioning feature.

•	 Once your video is uploaded and ready to view, follow these 
steps to add captions:

	 1.	 Navigate to your video, click Options.

	 2.	 Click Edit This Video.

	 3.	 Under Captions and Upload SRT Files, click Choose File  
		  to upload an .srt file with your captions.

	 4.	 Click Save.

Visit the Facebook Accessibility Help Center for additional 
information.

Instagram: Adding Alt Text and Video Captions

•	 To instantly become more accessible on Instagram, don’t  
use the Stories feature for primary business messaging 
purposes. Stories do not allow you to add alt text, captions, 
or a descriptive audio track to help visually impaired users 
know what you’re trying to communicate.

•	 Just like Facebook, Instagram tries to recognize common 
objects and concepts in photos and automatically generates 
alt text. It’s important to proofread this autogenerated alt text. 
A better option is to add your own descriptive alt text:

	 1.	 Select Advanced Settings.

	 2.	 Select Write Alt Text under Accessibility.

	 3.	 Add your alt text.

	 4.	 Select Save.

•	 For videos, Instagram does not allow users to add alt text, 
closed captions, or audio descriptions from within the app.

	 1.	 Write a detailed caption that describes what is happening  
		  in the video. If the video is short, you can include a  
		  transcript of what is said if there’s dialogue.

	 2.	 Another option is to use a different app to caption your  
		  videos before uploading them to Instagram (rather than  
		  recording them directly in the app). This option is best for  
		  longer-form IGTV videos.

Contact Information

It’s also important to make sure your contact information is 
available on your social media accounts, so people can easily 
reach out if they come across inaccessible posts. List a primary 
phone number and/or email address, or provide a link that lists 
the appropriate contact information.

Additional Social Media Resources

•	 LinkedIn: Adding Alt Text to Images

•	 “Inclusive Design for Social Media” (Hootsuite)

•	 “Five Easy Ways to Make Your Social Media More Inclusive”  
(Sprout Social)
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Accessible Websites 
APU Logo

The Division of Strategic Communication and Engagement 
provides downloadable versions of the APU logo in JPEG and 
PDF formats. By downloading the university trademark and 
logotype, you agree to adhere to guidelines outlined in the APU 
Graphics Standards Quick Guide (PDF). The JPEG files are  
high-resolution, 300 dpi Photoshop files used primarily for 
websites and Microsoft Word documents. The PDF/EPS files  
are Adobe Illustrator vector files used on print materials,  
T-shirts, giveaways, etc. Download the logos.

Headings

•	 Headings are ranked <h1> through <h6>, with <h1> being the 
largest and thus representing the most important idea on the 
page, with subsections organized with <h2> headings. These 
subsections can then be divided with <h3> headings, and so 
on. All pages should have only one <h1>, giving the title of  
the page.

•	 Use headings to categorize information and allow people to 
scan your page easily. Screen reader users can also benefit 
from headings, as they can navigate a page according to its 
headings, listening to a list of all headings and skipping to a 
desired heading to begin reading at that point.

•	 Do not skip heading levels to be more specific (for example, 
do not skip from <h2> to <h5>). It is, however, permissible to 
skip headings in the other direction if the outline of the page 
calls for it (for example, from <h5> to <h2>).

•	 Do not select heading levels based on their appearance. 
Select the appropriate heading rank in your hierarchy.

•	 Do not use bold instead of a heading. 

•	 Most content on web pages should be organized into 
sections. When pages are organized into sections, a heading 
should be present with each section.

Heading level 1 
It’s the large title at the top of the page. Use only one <h1> 
element per page or view.

Heading level 2 
This is the title of each main subsection, and each main 
subsection can be further broken up into smaller sections 
using <h3> through <h6> as follows: 

 

Heading level 3
Heading level 4

Heading level 5

Heading level 6

Text, Lists, Tables, and Media

•	 Include alt text for images.

	 °	 Use alternative text (alt text) for images, logos, drawings,  
	 and other graphic elements. Without alt text, screen reader  
	 users just hear “image.” Some images automatically  
	 include alt text, so it’s a good idea to check that the  
	 alt text is what you want. Read more about it in the  
	 “Accessible Images” section of this document.

	 °	 Check for high color contrast.

•	 To make your site easy to read, use large, left-aligned  
text when possible. Full-justified text is more difficult to  
read because of the extra space it creates between words.

•	 Use numbered and bulleted lists.

•	 Tables are structured sets of data that help people  
understand the relationships between different types of  
information. Use the caption element to provide a title for  
the table.

•	 Media includes content such as prerecorded and live audio  
	 and video. Make sure your media do not autoplay. 

	 °	 Check to see that all media can be paused.

	 °	 Confirm the presence of captions for videos.

	 °	 Confirm that transcripts are available for audio.

Additional Resources
ADA Standards for Accessible Design 

Making Audio and Video Media Accessible
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Creating Accessible PDFs in 
Adobe Acrobat Pro
There are many programs (Word, Excel, etc.) whose documents 
can be converted to PDFs, and directions for doing that can be 
found in various places on the Internet. Once you’ve created 
a PDF and would like to make it accessible, we recommend 
opening it in Adobe Acrobat Pro and following these steps:

1.	 Open PDF file.

2.	 Go to: File → Properties → Description.
	 Make sure Tagged PDF: Yes.  
	 (It must say yes to be an accessible PDF.)

	 Under Advanced, select English as the language, then  
	 click OK.

3.	 View → Zoom → Reflow to see the order things are read.  
	 Then turn Reflow off once examined.

4.	� Go to: Tools Pane → Accessibility → Reading Order 
→ Show Order Panel. In the Reading Order window, make 
sure “Display like elements in a single block” is unchecked.

In the Order Panel, make  
sure the reading order is  
correct. 

If not, click and hold any  
item in the order panel and  
drag it to the correct position  
in the panel.
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5. 	�Right click on each element in the Order Panel to assign it 
the proper tag. 

 ���•	� The very first header of a document should be tagged as 
heading 1 (<h1>). Note:  
There can only be one <h1> 
per document, similar to  
a webpage.

 ���•	� Secondary headings should 
be tagged as heading 2 
(<h2>). Tertiary headings 
within this space should be 
tagged as heading 3 (<h3>) 
and so on. 

���•	  �Background or decorative 
elements (graphics not 
containing vital information) 
should be tagged as  
background/artifact.

���•   �Sentences of a similar nature 
should be grouped together 
as a paragraph. Select the first 
sentence of the paragraph, 
hold down the shift key, and 
select the last sentence of 
the paragraph. Once your 
entire paragraph is selected, 
right click and tag as text/
paragraph (P).

6. 	�Tag images with vital text as figure/caption. Afterward, go 
to: View → Show/Hide → Navigation Panes → Tags and 
open the Tags panel. Locate the image you just tagged, and 
right click Properties. This will open up a dialog box where 
you can enter alternate text to make the image meaningful to 
those who use a screen reader.

7.	� Review your tags. Go to:  
View → Show/Hide → 
Navigation Panes → Tags 
and open the Tags panel. 
Expand the Tags palette by 
clicking the arrow next to 
tag to see the structure of 
the document. If nothing is  
in there, then the document is not tagged.

8. 	�Once your tag order is satisfactory, preview the screen 
reader experience. Go to: View → Read Out Loud 
→ Activate Read Out Loud. Then, starting on your 
document’s first page, go back to View → Read Out 
Loud → Read to End of Document. Listen for any 
inconsistencies or incorrect reading order. Note: you can 
change the voice speed in Preferences.

9. �Go to: View → Show/Hide  
→ Navigation Panes→ 
Bookmarks. Click on the 
drop down arrow and select 
New Bookmarks From 
Structure. In the dialog box 
that opens, select your 
relevant structure types  
(<h1>, <h2>, and <h3>, for  
example) and click OK. This will create document 
bookmarks that a user relying on assistive technology  
can access. Make sure to label the bookmark group.

10.	 Full Check

	� Make sure the boxes are checked like below and click Start 
Checking. If there are issues, right click on the issue and 
click fix; this should give you options on how to fix the issue.

11.	Once all the issues are fixed, save the document. 
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Video
Accessible videos have three main elements:

•	 Captions – The audio parts of your video appear as text at the 
appropriate time to give access to people who are hearing 
impaired or deaf.

•	 An audio description – A description of a video’s visual elements 
gives access to people who are blind or visually impaired.

•	 A 508-compliant video player – On the user side, it’s important 
that people who require keyboard navigation or an assistive 
device have access to a compliant video player to easily 
navigate to the window where the video plays.

Things to Consider During Storyboarding and 
Postproduction

•	 Avoid anything that flashes more than three times in any  
one-second period, as this can trigger seizures.

•	 Consider speaker visibility: Some people use mouth movement 
to help understand spoken language. When feasible, ensure 
that the speaker’s face is visible and in good light.

•	 For any overlay text used on screen, consider the font family, 
size, and contrast between the text and background to ensure 
it is readable. Download the Color Contrast Checker tool to 
assist with this.

•	 Plan for audio description of visual information: Using 
description provides context for people who are blind and 
others who cannot see the video adequately. It describes 
the visual information needed to understand the content, 
including text displayed in the video. Plan to either:

	 °	 Integrate description into the main audio content, or

	 °	 Record the audio and video with timing to accommodate  
		  separate description.

Add Captions and Subtitles

Captions and subtitles ensure that content is available for 
people who are deaf and others who have difficulty hearing 
the audio. Captions are also used by people who process 
written information better than audio. The terms “captions” and 
“subtitles” are used to describe this text in different regions of  
the world. This resource uses:

•	 “Captions” when referring to the same language as the 
spoken audio.

•	 “Subtitles” when referring to spoken audio translated into 
another language.

Some regions use “subtitles” for the same language as the audio 
and for the translation. Sometimes they are distinguished as 
intralingual subtitles (same language) and interlingual subtitles 
(different language). Subtitles are implemented the same way 
as captions. Subtitles/interlingual subtitles are usually only the 
spoken audio (for people who can hear the audio but do not 
know the spoken language). They can also be a translation of  
the caption content, including nonspeech audio information.

Captions are needed for accessibility, whereas subtitles in other 
languages are not directly an accessibility accommodation.

Does My Video Need Captions?

Video only (no audio content):

•	 For prerecorded and live:

	 °	 Captions are not needed, because there is no audio 	  
	 information.

Video with audio content:

Does the video have audio information that is needed for the 
audience to understand what the video is communicating?

If no (for example, it is just background music):

•	 Captions are not needed; however, if the title of the 
background music or the tone of the music is critical to the 
emotional arc of the piece, it may be wise to include that 
information in a caption.

If yes:

•	 For prerecorded and live:

	 °	 Captions are required to provide the audio content to  
	 people who are deaf or hard of hearing.

	 °	 Recommended resource for creating ADA-compliant  
	 captions: rev.com

References 
https://www.w3.org/WAI/standards-guidelines/
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https://digital.gov/2014/06/30/508-accessible- 
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Accessibility Education Webinar: Social Media 
Siteimprove

“Inclusive, by Design” by Derek Featherstone 
An Event Apart conference

Deque accessibility webinars

Contact Us
If you have questions or would like more information about  
issues related to accessibility, contact the Office of Accessibility 
and Disability Resources at disabilityservices@apu.edu or 
the Division of Strategic Communication and Engagement at 
stratcomm@apu.edu.
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